Home   ·   Index   ·   Search

Idiom Desktop Workbench STP instructions


Idiom Desktop Workbench Documentation

Installation

The installer for Idiom can be found in the folder here \\FS\Tech\ReadOnly\_LT\Installers\Idiom WorldServer Desktop Workbench. Follow the instructions in the .txt file. After installing the tool, it's ready to use with no licencing or activation needed.

Opening an .xlz package

Idiom projects come as "packed" .xlz files that contain the files for translation and any TMs and termbases. They are extracted for translation, and then exported into a "packed" version again for delivery.

Simply double-click an .xlz file to start importing it into Idiom Desktop Workbench (or launch Idiom, go to File > Open, browse to find the .xlz kit, select it and click Open). Idiom will now prompt you to import the file and resources to default folders located in My Documents\Idiom:

  • My projects (.wsprj)
  • My TDs (.wstd)
  • My TMs (.wstm)

You can select other target folders to save the file and resources (or connect to existing resources) but usually importing to the default folders is ok.

You will usually have the Create a new translation memory option selected. Only use the Add entries to existing translation memory if you have a previous TM and have been asked to use that. Repeat again for the Term Database.

Once you are ready, click OK.

Saving and reopening a project

Note that every change that you make in the files will be automatically saved in the wsprj file, you do not need to save the project specifically.

You must NEVER load/launch the same project in Idiom by opening the .xlz file more than ONCE, i.e. only the first time you load the project. If you do that without changing the location of the project files, you will overwrite the translation files created the first time round and lose your work.

If you have to stop translating and close Idiom Workbench while working on a project, e.g. if a job spans over two days, you have two options when it comes to carrying on where you left off the last time you closed Idiom Workbench.

  1. You open Idiom Workbench via the start menu or desktop, i.e. by clicking the application icon that starts the program. You then get a blank application window with no project loaded. You then load your most recently processed project via the File menu, where it will be listed as project 1 in the list of recent projects at the bottom of the File menu.
  2. You make sure to export your project before you shut down the Idiom Workbench application, which enables you to launch the project again to carry on working by double-clicking the exported project file.


File Analysis

Go to Tools > Scoping to analyse your files. The scoping function is quite similar to Trados analysis function, it displays the number of ICE matches, 100%, fuzzy, etc. You can choose between characters, words, segments and placeholders to perform the analysis. Note that this analysis is a snapshot from when the file was exported from Worldserver; it is NOT updated during translation.



Translation Process