Home   ·   Index   ·   Search

MemSource for translators


MemSource FAQ (translators)

MemSource is a cloud-based CAT tool which has many similarities with memoQ. The MemSource Editor is an offline client for editing MemSource translation files (MXLIFF). It is free to download and use.

The full user manual for MemSource Editor can be found here: http://wiki.memsource.com/wiki/MemSource_Editor_User_Manual


MemSource server credentials

An STP PM will be provided with unique server credentials (servername, username and password) for each project.
Note that you should NOT use these credentials to log in to a MemSource cloud server directly. They should only be used in the MemSource Editor to access the online resources.


MemSource editor installers

STP inhouse staff: \\fs\tech\ReadOnly\_LT\Installers\MemSource
Freelancers: http://www.memsource.com/download-site/

All work in MemSource should be performed on the MXLIFF files provided by the PM using the MemSource Editor.
Please do not work directly on the MemSource web editor.


Translating in MemSource Editor


Opening a project for translation

When a PM sends you a project in MemSource, it will consist of one or more MXLIFF files to open in the MemSource Editor. Open the MemSource Editor, and go to File > Open to select your files.

Connecting to project TM and TB

The first thing you need to do is enter the user credentials provided by the PM (you might be prompted for these as soon as you open MemSource Editor).
Enter them under Tools > Preferences > Login. If they are correctly entered, the Login button in the bottom right of the editor will light up green. You will also see a green light next to any project resources you are connected to.
Without correct login info to match the file(s), you will not be able to access the TM, TB and other resources on the client MemSource server.


Translating a segment

Every segment in the file must be confirmed before delivery. Confirm with Ctrl + Enter. You will see a green tick mark appearing next to the segment when it's confirmed.

Checking the TM/TB/MT matches

The MemSource Editor layout is very similar to memoQ. On the right hand side, you will see the matches from the TM (green, always at the top), followed by entries in the Termbase (yellow), followed by the machine translation (MT) suggestion (blue). You will only see MT suggestions if the client project manager has switched this on. Use the shortcut CRTL+[number] to insert a match entry into the target segment.

Using concordance

You can do a concordance search in the TM and TB by highlighting the words you want to search and using the shortcut CTRL+K for a fuzzy search, or CRTL+Shift+K for an exact search. You can also use the Search tab in the lower right-hand corner.

Adding a comment

You can add a comment in a segment by clicking on the comment icon (speech bubble) next to a segment.

Joining and splitting segments

You can split segments by placing your cursor in the source segment in the location where you want to split the segment in half, and using CTRL+E. To join segments, select the first one of the segments you wish to merge and use CTRL+J. This will merge it with the segment below it.

Filtering and sorting segments

You can filter for segments using one or more filters at the same time. Click on the triangle at the top of the editor view to show and hide the filter options. Tick the boxes for the filters you want to apply. To clear the filters, untick the boxes.

Use the source and target segment filter panes on top of the translation editor to filter for segments containing specific words or characters. If you want to use Find or Find and Replace, use the shortcuts CTRL+ F and CTRL+H respectively.

You can also sort segments in this same window. Select the sorting option you want, and select No Sort when you want to clear the sorting.



Saving a project

Make sure to save your work every now and then by going to File> Save or using CTRL+S. Remember to also confirm segments into the TM as you go along, to make sure you don't lose any work should the programme crash.

Keeping track of your progress

At the very bottom of the screen you can see a pane listing the number of segments, words, and characters in the file. The black number on the left is the total amount of segments/word/chars in the file, and the green number on the right is the number of confirmed segments/word/chars in the file. Make sure to mark segments as confirmed when you go along to update the figures.


Machine translation

IMPORTANT! Note that some clients will request an MT discount based on a post-editing analysis of the files. In practise, this means that any segment that you have translated with the help of MT (that is, where you have populated the segment with the MT suggestion) will be analysed based on edit distance. So the amount of text that remains unchanged in the segment is counted just like TM leverage. Read more on post-editing analyses here: http://wiki.memsource.com/wiki/Post-editing_Analysis

This in effect will increase your leverage and lower your compensation. If the machine translation is of high quality, it might be worth utilizing the machine translation, but it is still strongly recommended that you at the very least make sure not to let MemSource automatically populate your segments with MT. To avoid this, untick Insert machine translation (MT) in the MemSource Editor preferences (or in the same location in the Web Editor). This will ensure that only segments where you actively select an MT match from the translation results are analysed for MT Edit Distance in the post-analysis.

Keyboard shortcuts

 
Cheat sheet for Memsource 

After translation

Run QA by clicking the QA tab and then Run. This check should also check for spelling errors but you can also run the spellchecker separately by pressing F7.

File:Translation-quality-assurance.png

Delivery

Make sure that all segments are fully translated. Filter for Not Confirmed segments to ensure none exist.

Simply return the fully translated MXLIFF file(s) to the PM.