Home   ·   Index   ·   Search

Translating in Studio 2017


Translating in Trados Studio 2017

The main functions and keyboard shortcuts in the Studio Editor are listed in our SDL Trados Studio 2017 Cheat Sheet: Cheat Sheet Studio 2017.

Recommended STP settings for Studio can be found here: STP default settings for Studio 2017.

This FAQ explains how to translate project files in SDL Trados Studio 2017's Editor. The workflow assumes one of the following:

  1. You are a freelancer or an in-house translator and you have received a project package (.sdlppx) for translation or revision.
  2. You are an in-house translator and you have received a link to an unpackaged project folder structure (.sdlproj and folders) for translation or revision.
  3. You are a freelancer and have received a memoQ file (.mqxliff or .mqxlz) for translation.

Getting started

 

If you have received a project package (.sdlppx):

  1. Go to File > Open package and navigate to the .sdlppx package
  2. In the Open Package screen, make sure to select the folder where you want to unpack the project package
  3. Click Finish

If you have received a link to an unpackaged project:

  1. In Studio 2017, go to File > Open Project and navigate to the .sdlproj file.

If you have received a memoQ file (.mqxliff or .mqxlz):

  1. In order to work on a memoQ file, please first check your file type settings for memoQ files are as recommended here to avoid Studio locking segments automatically.
  2. Click File > Open > Translate Single Document
  3. Select file type XLIFF: Kilgray MemoQ Documents, navigate to the MQXLIFF or MQXLZ file you have received and click Open.
  4. In the next screen, source and target languages will have been auto-detected. If you have received a TMX file, you need to create a a blank TM and import the TMX file into it:
    1. Click Create > Create Translation Memory.
    2. Give the TM a name and save it in the location of your choice.
    3. Select the new TM and click Import.
    4. Click Add Files and navigate to the TMX file you have received.
    5. Click Next twice, then Finish. Finally click Close when the TMX has been imported.
  5. Click OK to finish setting up the document for translation.

Opening files for translation/review/sign-off

In the Home ribbon, go to the Projects view in the lower left-hand corner of the screen and double-click on the project in the project listing in the main window.

Go to the Files view in the lower left corner. If the project has multiple languages, select the correct target language from the upper left corner. Select all files, right-click and select Open for Translation.

Note that selecting multiple files to open creates a combined editor view of the files. 

You can use the file tree on the left hand side to navigate between different files when necessary.


Working with TMs and termbases

Any TMs and termbases belonging to the project are loaded automatically. TM matches (= Translation Results) and termbase matches (= Term Recognition) have their own windows in the Editor view. You can customise your Editor view in the View ribbon.


If there is no existing termbase within the package but you want to add an external glossary, you must first put the external glossary into Multiterm. Then, go to Home ribbon > Project Settings. Select Language Pairs > All Language Pairs > Termbases. Click on Use > File-Based MultiTerm Termbase and load the termbase.

If there is no TM within the package and "No open translation memories" is displayed in the Translation Results window, you can add a blank TM to the project. Home ribbon > Project Settings. Select Language Pairs > [your language pair] > Translation Memory and Automated Translation. Click on Create and select Create Translation Memory.

If you want to add an existing TM, use the Use button instead of Create.


When you create a new TM, in the New Translation Memory dialog on the first page, give the TM a name and save it in the location of your choice. Click Next, and Next again to skip the next 2 pages, then Finish and Close after Studio has finished the process. Click OK to close the Project Settings and return back to the Editor view to continue with the settings below.

If you need to connect to a server TM or server TB for your project, Studio will usually prompt you to enter the credentials as soon as you open the files for translation. Select Use SDL authentication and enter the login credentials you've received from your PM.


 If you are not prompted for the credentials but you know you should connect to a server TM or TB, go to Home ribbon > Project Settings. Select Language Pairs > All Language Pairs > Termbases / Translation Memory and Automated Translation. Click on Use > Server-based MultiTerm Termbase / Translation memory.

If you've connected to the same server before, you might see the server URL in the list. If not, click on the Servers... button and then Add... which will launch a prompt for you to enter the server URL and login credentials.


Translating

Click on the first empty target column line on the lower right window and enter your translation. Pressing Ctrl + Enter confirms the translation and moves to the next unconfirmed segment. If you start typing a translation but move on to the next segment without confirming it, it will get the status Draft.


Filtering for specific content

You will find Display Filter options in the Review ribbon.


If you want to combine two or more filters together, go to View > Advanced Display Filter.

Applying TM matches

To perform a lookup and apply a translation:

  1. In the Editor view, select a segment. If any matches are found, they are displayed in the Translation Results window. The first (best) match is displayed in full, other matches are minimized.

  2. If more than one match has been found, view the other matches by clicking the Select Next Match and Select Previous Match buttons in the Translation Results window. Alternatively, you can press Alt+Page Up and Alt+Page Down.

  3. Decide which match is to be applied and make sure that this match is currently displayed in the Translation Results window.

  4. Click the Apply Translation button in the Translation Results window or click Ctrl+T.

Buttons in the Translation Results window

NOTE! By default, a lookup is performed in the translation memory automatically when you place your cursor in a segment. However, if this feature is not selected you can manually perform a lookup. This default behavior is controlled by a setting on the Options dialog box. To view or change this setting, select File > Options > Editor > Automation

Inserting Termbase matches

Term translations can be inserted from your termbase search results into your active document in the Editor view.

  1. Place your cursor at the point in the target segment where you want to insert the term.

  2. Select the term translation that you want to insert from the Term Recognition window or Termbase Search window and click the Insert term translation button.

  3. Alternatively, select ctrl+shift+L.

Concordance

You can search for concordance by selecting text in the source OR target column and pressing F3.

Splitting a segment

If you need to split a source segment, click in the desired location in the source column, right-click and select Split segment. To combine source segments, select the desired segments by keeping the Ctrl key pressed and clicking the segment numbers on the left of the source column, right-clicking and selecting Merge segments. Combining segments is unfortunately only possible for segments in the same paragraph, so this option is often greyed out.

Formatting tags

By default, Studio doesn't display formatting tags. You can change this in the Editor settings (see STP recommended default settings for Trados Studio 2017) or toggle it on/off using the button on the View ribbon > Options.

Adding a comment in a segment

To add a comment in a file, right-click on the relevant segment and select Add Comment. This will open a dialogue box where you can select the severity level and write your comment. Please note that you can only add a comment in a file if you have opened it separately, not as part of a view with multiple files - if you try to do it in a view with multiple files, you will get an error message.


Source and target preview

You can see both the source text and your translation in proper context by going to View > Preview. This opens a window where you can select if you want to view the source or target document, or both of them side-by-side. You can also select the format you want to view the document in.


Keeping track of your progress

In the editor view, the numbers in the lower right hand corner of the screen indicate your progress.

 

You can also keep track of it by going to the Files view and the Confirmation Statistics tab. You can select either one or multiple files, and the numbers (shown either as word counts, percentages, or both) are updated as you translate the files. You can also see a general progress bar next to the file names in the Files view.



Saving a project

Make sure you use Ctrl + Shift + S as your save option at all times. Ctrl + S only saves in the currently viewed document and if you move between documents, changes can remain unsaved.


Autosuggest dictionaries

The autosuggest dictionaries in Studio are now much more useful than before. It is now possible to generate an autosuggest dictionary from a reasonably-sized TM as well. Previously you needed a TM with hundreds of thousands of entries.

First, you must enable Autosuggest from in your general options, under File > Options > Autosuggest.


To create an autosuggest dictionary for an individual project, go to Project Settings > Language Pairs > (your language pair) > Autosuggest Dictionaries

Click "Generate" and browse to your project TM(s). It sits within the folder structure underneath the unpacked project. Try leaving the slider in the default position in the "memory usage" dialogue. It takes a minute or two with a decent size TM.

If all went well, you should now start seeing something like this during the translation process:


Move the highlighting to the entry you want with the down and up arrow keys of your keyboard, and enter the desired item into the target field by pressing the Tab key.


Inserting tags and other placeables

There are several ways to insert content from source to target easily. You can:

1. Insert Tags by Copying and Pasting

Simply copy + paste a tag from the source into the target segment.

2. Insert Tags from a Source Language Segment

  1. In the Editor window, click inside the target segment where you want the tag to be inserted or select the text that you want to be enclosed in tags.

  2. Place the cursor over one of the tags in the source segment press Ctrl. The tag and the text that it is encloses are highlighted in gold.

  3. Hold down the Ctrl key and click on the tag in the source segment text. The tag pair is inserted into the target segment at the point where the cursor is located. Click inside the tag pair and start typing. Alternatively, if you had selected text in the target segment, that text is now enclosed in the tag pair.

3. Insert Tags from the QuickInsert Group

  • In the Editor window, select the text to be formatted and click the required button on the QuickInsert Group. The tag formatting is applied to the selected text. Or,

  • In the Editor window, place the cursor in the target segment where you want the tags to be inserted and click the required button on the QuickInsert Group. The tag pair appears in the target segment. Click inside the tag pair and start typing the text to be formatted. When you have finished typing, click outside the tag pair.

QuickInsert Group in Studio Home ribbon:


4. Insert Tags from a QuickPlace Drop-down List

  1. When the cursor is at the point where you want to insert a tag in the Editor window, press Ctrl+,(comma). A drop-down list of tags is displayed below the target segment.

    tag_list.jpg

  2. The first tag is selected automatically. In the source segment, the text formatted by the tag is highlighted.

    • If this is the required tag, press Enter or Tab to insert the tag into the target segment. If the tag is one of a pair, a ghost tag is also inserted.

    • If this is not the tag you want to insert, select different tags until the correct one is selected and then insert the tag into the target segment.

  3. Continue typing. The selected tag formatting is applied to the text.

  4. When you want the formatting to stop being applied, press Ctrl+,(comma) to insert the closing tag of the pair. Alternatively, press Ctrl+,(comma) to display the closing tag closing_tag.jpg for selection.


If you are doing a revision in Studio, check if the project instructions ask you to use tracked changes. If they do, toggle on the Track Changes function in Studio under the Review tab before you make any changes in the files.
If you want to view the revised translation without the tracked changes, use the Final Mode button to toggle the changes on and off momentarily.

If you are finalising a file that has been revised using tracked changes, make sure to either accept or reject all changes in the files, and make sure all segments are confirmed before you deliver any finalised files.

Final checks

Spell-check the finished translation with Review > Quality Assurance > Check Spelling. Note that Studio uses Hunspell dictionaries as default, which do not support Finnish very well. FI translators will need to use MS Word dictionaries instead. See STP recommended default settings for Trados Studio 2017.

Verify tags and run a QA for checks specified in the STP default settings with Review > Quality Assurance > Verify. Note that just like when translating, you can do this in a view of all files, if you select and open all files at once. This saves time when verifying.



After running spellcheck and QA, make sure there are no untranslated segments left.

To mark several segments at the same time, select the first segment number, holding down SHIFT and selecting the last segment number, right-click and select the command you wish to carry out.


Using a custom QA profile

Sometimes a client might send their own custom QA profile to use with a project. You will recognise the file file from the extension .sdlqasettings, and you can import it into your project by going to Project Settings > QA Checker Profiles. Click on Import settings... and navigate to the file to import. Please note that importing a new QA profile will replace any previous QA settings for that project.

 

Using Terminology Verifier

The default QA settings should take into account and check any TB matches during the normal verification, but it could happen that the package you received was set up with less than optimal settings. If you run the QA for a project with a TB but don't get a single warning about terminology, it might be a good idea to check if the highlighted box under Project Settings > Verification > Verification Settings is ticked.

You can change the termbase that is being checked under Language Pairs > All Language Pairs > Termbases, either by adding another TB to the project or by changing which one is the default TB if there are multiple attached to the project. When you change the default TB and go back to Verification Settings, the termbase name on the top of the screen should have changed to the one you chose.



Delivery

Make sure that there are no untranslated (empty or draft) segments left in the files. To sign off files after translation, select all the files in the project and click Open For Sign-off under the Home tab. This will open the files in a combined view, where you can click Complete Sign-off under the Home tab. If you have not been instructed to mark the segments with Reviewed or Sign-off status, all segments you worked on should have Translated status. If you're unsure what status the final files should have, check with your PM.

The delivery method depends on the way you originally received the project:

If you received a project package (.sdlppx):

Right-click the project in the Projects view and select Create Return Package.
Select all files for delivery.
Select name and location for the return package, then click Finish.
Send the return package (.sdlrpx) to the PM.

If you received a link to an unpackaged project:

Simply notify the PM when you are ready.

If you received a memoQ file (.mqxliff or .mqxlz):

With the file open in the Editor, go to File > Save Target As (or click Shift + F12).
Save the translated file in the original format (.mqxliff or .mqxlz).
(Note that this workflow will also generate an SDLXLIFF file (which is the working format in Trados Studio), but it is not necessary to return this file.)