© 2014 Sandberg Translation Partners Ltd
Home   ·   Index   ·   Search

ApSic XBench

ApSIC Xbench

ApSIC Xbench is a versatile tool that can be used for powerful Concordance searches (source, target, TMs, glossaries) during translation, and QA before delivery.

Installing ApSIC Xbench

ApSIC Xbench can be downloaded from the ApSIC website at http://www.xbench.net/index.php/download. Version 2.9 is free of charge, but version 3 and onwards requires a subscription. (STP in-house staff will have 2.9 installed on their computers). You can accept all the default installation settings.

If you are running Windows 7, you may have problems viewing the Xbench help files. If this is the case then you need a Microsoft patch called Windows6.1-KB917607-x86.msu. STP translators will find it under \\vs1\Installers\_Other\Windows Help (WinHlp32). Simply run the Windows6.1-KB917607-x86.msu file and accept all the default installation settings.

Loading project files

Load your project materials into Xbench by going to Project > New. Click Add... to add new files. Using this function you can add all your translation files, TM and glossary files into the same Xbench project.

Check the file types your Xbench installation supports in the Xbench Help > Contents > Defining Search Projects, and select the type of file you wish to load into Xbench in the Add Files to Project dialog.

Once you have selected the file type, click Next. Navigate to the folder where the files are saved, select and click Open. Click Next again. You can now assign a priority to the files; this will depend on what priority the files in your project take. For example, translation files normally have a lower priority than a TM, and the TM a lower priority than the glossary. If this is the case, mark the translation files as Low priority, TM as Medium priority and glossary as High priority. Translation files should be ticked as Ongoing translation and glossary files as Key Terms. Click OK. Add all files for the project in this way and click OK when you are done.


Saving and reloading a project

You can save the entire Xbench project by going to Project > Save As. This will save a .xbp file which can be opened in Xbench again.

If you are using Xbench during your translation for Concordance searches, or want to run a final QA check again to see that all issues were fixed, you need to reload the file pairs again so that Xbench recognises the latest changes. Save the project and go to Project > Reload to reload. During translation, reload the project regularly in order to have your latest translations in the project.

Shutting down Xbench

Shut the application down by right-clicking on top of the Xbench icon in your system tray and selecting Shutdown Xbench. Closing the application from the X in the top right-hand corner when the application is open does not shut the application down but only minimises the view.

Using Concordance

You can run a Concordance search in all of the project materials based on the source or target text and different search options in the Project tab. The results will be displayed in priority order. Key terms from the glossary are indicated with a star.

Expand to view the source term, target term and search options fields in the Project tab by selecting Source term / Target term / Search options from the View drop-down menu.

Hitting CTRL + ALT + ENTER on top of a search result will launch the application where the search result is found.

NB! Unlike Trados' Concordance search, the Xbench search will search all your project files at the same time. You can search for both source and target terms, and the search results will also display any matches from your own translations.

When you are working in your translation files, you can launch an Xbench Concordance search by highlighting a term and hitting
CTRL + ALT + INSERT for source concordance search
CTRL + ALT + BACKSPACE for target concordance search

You can also see the context of a search result by selecting the segment in Xbench, right-clicking and selecting See Context.

Dismiss Xbench to the background by hitting Esc.

Running a QA check in translated files

Tick the general QA check categories in the Basic and Content categories under Check Group and List of Checks.

Tick Linguistic in the Check Group and Key Term Mismatch in the List of checks categories to check consistency with the glossary.

You can exclude XUs by ticking Exclude Locked Segments under Options.

Once you have determined the QA check categories, click Check Ongoing Translation. The results can be scrolled using the arrow keys. Hitting CTRL + ALT + ENTER will open the file and take you to the place where the error occurs for you to fix it.

You can export the error log as a .html file by right-clicking on top of the error results and selecting Export QA log.

More information

More information on advanced search and QA settings and adding Internet search engines and online dictionaries in Xbench for searching in can be found in the Xbench help.