Home   ·   Index   ·   Search

ApSIC Xbench


ApSIC Xbench

ApSIC Xbench is a versatile QA tool that can be used for a number of purposes. Many clients require Xbench QA reports as the tool used to be freeware. But it is a fast tool and very useful for handling large projects, so having a basic understanding of Xbench can be very useful for PMs as well as translators. Translators can for example use Xbench to concordance search a large number of TMs, glossaries or bilingual translation files, and the highly innovative spellchecker is a fast and useful alternative to integrated spellcheckers in memoQ and other tools.

There are 2 principal versions of Xbench. Version 2.9 is freeware and free to use, but lacks some features and support for recent file formats, requires manual installation of spellchecking dictionaries and may have compatability issues with recent operating systems. Version 3.0 is a licensed version. STP started using Xbench 3.0 in October 2014 and have a limited number of licenses. The yellow highlighted parts in screenshots below highlight the new features added to Xbench 3.0 when compared to 2.9. Please see Xbench help (Help > User's guide) for full details on these new features if unclear.


Installing Xbench

Version 2.9 (free)

ApSIC Xbench can be downloaded from the ApSIC website at http://www.xbench.net/index.php/download. STP in-house staff will have 2.9 installed on their computers but you might experience some performance issues - contact LT in that case. You can accept all the default installation settings.

If you are running Windows 7, you may have problems viewing the Xbench help files. If this is the case then you need a Microsoft patch called Windows6.1-KB917607-x86.msu. STP staff will find it under \\fs\Tech\ReadOnly\Installers\Microsoft Windows Help (WinHlp32). Simply run the Windows6.1-KB917607-x86.msu file and accept all the default installation settings.

In-house staff experiencing problems running Xbench version 2.9 can also run it as a remote app, which is more stable. See more details here.

Version 3.0 (paid)

ApSIC Xbench can be downloaded from the ApSIC website at http://www.xbench.net/index.php/download. STP staff will find it under \\FS\Tech\ReadOnly\Installers\ApSIC XBench\Version 3 (licensed)\. In-house users can receive a time-limited license from LT upon request - please send a 1ticket and explain the case and duration. Once an LT team member has allowed you access, you can open Xbench 3.0 and sign up using your STP email and a password of your choice. You will receive an email that requires you to verify your email address. Check the junk folder for the email and move the email into your inbox and then follow the link on the email to verify. After successfully doing this, you will be able to login using your email and the password you entered at sign up.

Important notes about Xbench 3.0:

  • Unless you need to use Xbench 3.0 in your daily work, which most STP users do not, your license for 3.0 will be revoked after the period that you need it for (as stated in your ticket request).
  • Xbench does not allow multiple installations per se, but you can circumvent this and keep both 2.9 and 3.0 installed if necessary. In order to do this, you need to make sure 2.9 is installed first, then move the entire folder where the program is installed to somewhere else (like the desktop) and then install 3.0. You can then run 2.9 directly from its folder and 3.0 from the start menu, but not simultaneously. Also note that 2.9 will prompt you to upgrade every time you run that version. Still, 2.9 is the version we regularly use at STP.

Loading project files

Load your project materials into Xbench by going to Project > New. Click Add... to add new files. Using this function you can add all your translation files, TM and glossary files into the same Xbench project. You can also simply drag and drop files into the project window.

Check the file types your Xbench installation supports in the Xbench Help > Contents > Defining Search Projects, and select the type of file you wish to load into Xbench in the Add Files to Project dialog.

Xbench 2.9

Xbench 3.0

Once you have selected the file type, click Next. Navigate to the folder where the files are saved, select and click Open. Click Next again. You can now assign a priority to the files; this will depend on what priority the files in your project take. For example, translation files normally have a lower priority than a TM, and the TM a lower priority than the glossary. If this is the case, mark the translation files as Low priority, TM as Medium priority and glossary as High priority. Translation files should be ticked as Ongoing translation and glossary files as Key Terms. Click OK. Add all files for the project in this way and click OK when you are done.

Xbench 2.9/3.0



Saving and reloading a QA project

You can save the entire Xbench project by going to Project > Save As. This will save a .xbp file which can be opened in Xbench again. This is useful if you have a client that requires Xbench reports against the same resources for every project – you can then create a project with, for example, the client glossary and custom checklist, and save this project. Then, next time you can simply load the project and add your translation files by going to Project > Properties, and then run QA.

If you are updating the files loaded into Xbench using the Edit Source function, you will need to reload the files to make these changes appear in the Xbench report. This is relevant if you for example update a term in a large project (to make sure all instances of the term have been changed) or when you correct QA errors and then want to run QA again to make sure it only contains false positives. To do so, the project must first be saved. Then go to Project > Reload to reload it.

Shutting down Xbench

Shut the application down by right-clicking on top of the Xbench icon in your system tray and selecting Shutdown Xbench. Closing the application from the X in the top right-hand corner when the application is open does not shut the application down but only minimises the view.


Running a QA check in translated files

QA check categories

Tick the general QA check categories in the Basic and Content categories under Check Group and List of Checks. 

A standard check in 2.9 includes Untranslated Segments, Inconsistency in Source, Inconsistency in Target and Target same as Source in the Basic category, and Tag Mismatch, Numeric Mismatch, Double Blank, Repeated Word and Key Term Mismatch in the Content category.

A standard check in 3.0 includes Untranslated Segments, Inconsistency in Source, Inconsistency in Target and Target same as Source in the Basic category, and Tag Mismatch, Numeric Mismatch, URL mismatch, Alphanumeric Mismatch, Unpaired Symbol, Unpaired Quotes, Double Blank, Repeated Word, Key Term Mismatch and ALLUPPERCASE Mismatch.

In certain situations, for example when the QA report ends up being too long, it might be advisable to untick Inconsistency in Source and/or Untranslated Segments for example, as they are the values that can most likely result in false positives and can be out of the translator's control (errors in the source or EN=EN segments). 

You can exclude XUs by ticking Exclude Locked Segments under Options.

Once you have determined the QA check categories, click Check Ongoing Translation. The results can be scrolled using the arrow keys. Hitting CTRL + ALT + ENTER will open the file and take you to the place where the error occurs for you to fix it.

Xbench 2.9


Xbench 3.0

Exporting a QA report

You can export the error log as a .html or .xls file by right-clicking on top of the error results and selecting Export QA log.

'Edit Source' function

You can also right-click in any error flagged in Xbench and select Edit Source to open the file in its native format and be directed to the exact sentence/phrase to be edited. Bear in mind that to do this you need to have the software that opens that file format installed in your computer. This means that you can open an sdlxliff file only if you have access to Trados Studio for example.

To update these changes in your QA report, save the Xbench project first and then reload it from Project > Reload.


Using a custom checklist

Use Checklists to add any checklist you might have added for a specific client to your QA project. These can be added by going to ToolsManage Checklists, which will open the Checklist Management window. Just drag and drop the checklist(s) you need to use for a project and press ok.

Before running the QA, check that the correct checklist is ticked under Check Group > Checklists.


Reading a QA report

It's important to realise that while Xbench is a very accurate QA tool, like any of these tools it is not perfect. When reading a report generated by it, there are undoubtedly going to be instances of false positives, so there are a few key points to take into account:

- most instances of "Target Same as Source" are usually false positives, as these are either left like the source has it for a reason or are number-only segments that don't need localisation;

- depending on the quality of the glossary used for the check, even some key-term mismatches can be false positives, so watch out for those;

- if you see a lot of "untranslated segments", chances are the file loaded into xbench is either not the final one or a corrupted version, so double check what should be used for the check;

- depending on the format of the file you are using, even some tag mismatches might be false positives, as xbench might read as tags characters that are just part of the text like [,< or {;

The aim of a report is to identify quickly and efficiently the actual errors that might be present in a text, so if you find that your Xbench report is way too extensive and filled with false positives, try tweaking the check settings to reduce the clutter and speed things up.

You can run a Concordance search in all of the project materials based on the source or target text and different search options in the Project tab in Xbench 2.9 and in Search tab in Xbench 3.0. The results will be displayed in priority order. Key terms from the glossary are indicated with a star.

In Xbench 2.9, expand to view the source term, target term and search options fields in the Project tab by selecting Source term / Target term / Search options from the View drop-down menu.

Xbench 2.9