Home   ·   Index   ·   Search

Alchemy Catalyst


Catalyst

Alchemy Catalyst is a software developer tool which can be used for translating software strings. There are two different versions available to translators: a free Lite version and a paid Translator/Pro version.

This FAQ gives you some basic information about using Catalyst, please refer to Catalyst Help for more information. Getting started > Basic Steps for projects > Getting started quickly is a good place to start.

Versions, builds and installation

In order for a project to be translatable in the free Lite version, it needs to be prepared specifically for it. Check with the client whether the project can be opened and translated in Lite if the translator doesn't have the full Translator Edition version.

The software build is sometimes specified by the client. Use the exact (or higher) build specified. If you have a lower version, check with the client if they can provide a patch to update your installation.

STP in-house translators and PMs can install the full Catalyst 10 Translator Edition version from \\FS\Tech\ReadOnly\_LT\Installers\Alchemy Catalyst 10. After installation, the licence is picked up automatically (Catalyst uses a licence server on the network).

Freelance translators can download Lite from the Alchemy website http://www.alchemysoftware.ie/translite.html where there are also options to purchase a full version.

Source kit

Catalyst projects come as .ttk kits which contain the files for translation and TM content along with a glossary if applicable.

Opening a project and orientation

Launch Catalyst. Tick Open existing file and browse to the location where the .ttk kit is saved. Click Open and OK and the project will open in Catalyst.

NB. If you cannot see the below mentioned toolbars or views, activate them from the View menu first.

On the left-hand side, you will see the Navigator view. Make sure you are at the top of the source folder structure. Clicking on the A icon will display all strings within the project.

You can filter strings by different criteria in the Look In > Filter drop-down list. For example, if you have been requested only to process segments marked For Review or Untranslated, you can select them from here. Usually strings marked Signed Off or locked strings do not need to be processed again, but please follow client-specific instructions on which strings to work on.

The translation is carried out in the Translator Toolbar where you type in your translation in the top field. You will be able to see reference, TM and glossary matches in the relevant tabs as you move from one segment to the next. The Reference tab displays TM matches along with machine translation suggestions if this option has been activated.

Adding a TM or glossary

If no TM is displayed in the Active TM tab, you can attach one yourself. Please do this even if you don't have existing TM content to leverage as you won't otherwise have the benefit of matches and concordance as you move through your own translation.

Add a TM by clicking on the add TM and browse icons  and selecting the TM you wish to use. You can add full Trados TMs (.tmw), .tmx exports, previously translated .ttk kits and also other reference TM/content sources to Catalyst Translator/Pro. Catalyst Lite only supports TMs exported to TMX. Catalyst supports multiple TMs loaded at the same time.

Add a glossary in the same manner in the Glossary source tab. You can add .txt based glossaries for Catalyst or .tbx compliant glossaries from Multiterm, for example.

Translating

Use the commands and keyboard shortcuts in the PowerTranslate toolbar. ALT + HOME is the command that brings a translation from the TM into the target segment, and ALT + END sets the translation in the TM. Use CTRL + SHIFT + N to move to the next segment, but not that this does not store the translation in the TM. Remember to save the project regularly.

NB. If you have a problem with ALT + END not storing translations correctly in the TM, a fix is to regularly export the translations as .ttx and clean the .ttx in the Trados TM connected to the project.

Also, if you are using a Catalyst TM, do note that they have a size limit. If you can't save new segments into your TM it is likely that it has reached its maximum size. 

It's usually advisable to first filter on and translate Duplicates and then move on to the rest of the untranslated or other strings that require processing. The repetitions of a translated string can be automatically propagated to all identical segments using ALT + DOWN ARROW. In the absence of client-specific instructions on string status, the translator can set all translated/processed strings to For Review. The reviser should retain this string status.

You can see the strings as they will appear in the original file if you switch on View > Workspace > Visual View. Occasionally the project may contain memos and locks. You can see them in the Visual View, refer to them for reference as they may contain hints from the client.

Punctuation

Make sure that all colons, hyphens, slashes and end of string punctuation is preserved in the translation as it is in the source. For example, a colon at the end of a message often indicates a search field label which will appear in a list with other labels ending in colons. Follow this guideline even if it contradicts your own language rules.

Capitalisation should follow conventions for your target language. For example, labels and headings might use initial capitals rather than title case (Quick search not Quick Search).

Parameters and string length

Parameter %d always represents a numeric value. Where the target language has multiple plural forms for nouns, any nouns related to a numeric value parameter should use a generic plural form which is acceptable in all cases. Parameter %s can be a numeric or other value. A contextual note is normally included with these strings.

Try to avoid translations that exceed the length of the English original by more than 25%, particularly for button text and navigation links.

Spellchecking

Hit F4 to run spellcheck. If no spellchecking dictionary is loaded, go to Tools > Options > Spell Check to load the Microsoft Word dictionaries. Unfortunately Catalyst seems to require Office 2007 or higher for the spellcheckers to work, so if you don't have 2007 or 2010 installed on your computer, the only other option is to export the translation as .ttx and spellcheck in TagEditor. Implement all changes in Catalyst, not in the exported .ttx file as it can't be imported back.

QA

Before final delivery, run the Validate Expert from Tools > Validate Expert. Set the validation options in the Options tab and select all object types in the Object Types tab, and define a report type if necessary in the Report tab before clicking OK to run the validation. These can be used as default options guidelines: