Home   ·   Index   ·   Search

SDL Passolo


Installation

SDL Passolo Translator Edition is an SDL application used for translating software strings. There are several versions of the free translator edition: 2007, 2009, 2011, 2015 and 2016. STP in-house translators and project managers can install the required version from the Installers folder, and these same installers can be provided to external suppliers. Using Passolo does not require any sort of licencing. 

Note that there are other versions of Passolo like Passolo Essential that are associated with generating translation projects. These can NOT open bundles for translation, so make sure you are only using Translation Edition versions when working with Passolo (PMs as well as translators).

The Passolo version required will be apparent from the file name:

Passolo Translator Edition version Bundle format
2007 *.tbulic700
2009 *.tbulic800
2011 *.tbulic11
2015 *.tbulic15
2016 *.tbulic16

Earlier versions of Passolo cannot open files from a later version, and later versions cannot open files from an earlier version. You can keep installations of the different versions on your computer without them interfering with each other. Please note that the Translator Edition cannot parse source files or generate target files, nor open translation bundles which have not been set up and exported by the client to be opened in the translator edition.

NOTE! Until Passolo 2015, any Passolo Translator Edition version could only open the bundles associated with that version. But it has turned out that Passolo 2015 Translator Edition CAN in fact open older bundles. However, this may create problems for the client, so please ONLY use the Passolo version associated with the bundle format. It is strongly recommended to always open the Passolo version you need to use from the Start menu and then open the package from within the software rather than double-clicking on the file.

Passolo 2015 introduced a ribbon interface and much of the UI which was more or less identical between the other versions is very different in 2015. The below instructions are duplicated where necessary to show differences between 2015 and older versions.

This document focuses on basic instructions for new users. More settings can be found on the Advanced Passolo wiki page.


Changing ID

By default, Passolo uses your Windows user ID. For STP users this is fine, but freelancers should set their username to XX@STP where XX stands for your initials. To do this, go to File > Options > Users (2011: Tools > Option)


In the User dialog that opens, click Add to add the new user name. Restart Passolo for the change to take effect. When starting a new project, select the new user name before you open a bundle for translation in Passolo.

Initial settings

Most of the below settings only need to be set once for the translator edition. Go to File > Options (2011: Tools > Options) and tick or select the below marked settings.



Use the below settings for all of the Translation Helpers > Pre-Translation / Fuzzy Matching / Concordances / Terminology views.

(You can read more about attaching external glossaries below)


Settings for replicates should mirror the below screenshot. Note that we are often not paid for repetitions in Passolo projects. The below settings ensure that any repeated segment is only processed once.


The below settings for the Translation Assistant need to be set once only, but the Translation Assistant should be activated by ticking Use Translation Assistant or via the translation view icon every time you use Passolo. Change these settings according to client specification or your own preference if need be.



Opening a project

Launch Passolo and click Open on the Home ribbon or from the File menu. Select the bundle you want to open and click Open. You can also double-click the Passolo bundle to automatically open the file in the correct Passolo version. The following project dialog opens:




The Translation Bundle screen will contain all files that are part of the bundle. You can double click a file to open it, but most Passolo projects will contain a large number of files, and most of the total content will be out-of-scope validated translations, so it is usually easier to open all files at once and then filter for the content in scope.


To open all files, select them all (CTRL + A), right click and Open String List.


This will open the segments for editing.


Analysing a project

You can display analysis results for a whole project by going to Statistics on the Home ribbon (2011: String List > Statistics). Statistics for individual files will be displayed if you click a file name on the left.

 


Strings colour codes

  • Red text has yet to be translated.
  • Blue text has been manually translated but not yet reviewed.
  • Green text has been pre-translated but not yet reviewed. It can be a perfect match or a fuzzy match.
  • Black text has been translated and validated. It is normally out of scope and locked for editing.

Note that as soon as a "red" and "green" translation is edited, the colour of the segment turns blue, and it can be difficult to distinguish newly translated blue segments that may still need to be revised, from blue segments for review from the original translation bundle. If you are revising "blue" strings as well as translating, consider filtering for and reviewing the blue strings only, then move on to the red and green strings. (More about filter settings below)

Please make sure there is a clear agreement on who should revise existing blue strings, the translator or reviser. Newly translated red strings that turn blue as soon as a translation has been entered can still be identified by their user ID. You can sort strings by the User column.